Thursday, 11 January 2024

Dynamic Routing Configuration – RIP, IGRP

 

Dynamic Routing Configuration – RIP, IGRP




















I think If you followed the previous posts that I published under IP configuration in CISCO Packet tracer software, this won't be a big task for yu to design and load the above network now.

Follow the steps below one by one so that you will be learning how to perform dynamic routing configuration without having doubts. Though the steps are almost similar to the previous post, I'll be mentioning the commands of CLI then and there as necessary.


Step1: Design the above network and load it in to Packet Tracer Simulator.

Note:   For R1 and R3 - Router 1841.            For R2 – router 2811
            Select R1 – S0 and R2 – S1 as DCE side for clocking inside the simulator.

Step2 :Name R1, R2 and R3 as Malabe, Metro and Matara.


Router(config)#hostname MALABE
Router(config)#hostname METRO
Router(config)#hostname MATARA

Step3 : Design a suitable IP plan for the above networks.

For simplicity, the IP plan is marked clearly in the above diagram it self making easy for you to understand. I have used subnetting in the very similar way that was used in the previouse post (STATIC ROUTING AND DEFAULT ROUTING CONFIGURATIONS)

Step4 : Configure the Serial and Ethernet interfaces of routers.

Step5: Assign clock rate as 64000 for the R1 serial 0 and R2 serial 1 interfaces.


For Router1
MALABE(config)#interface fastEthernet 0/0
MALABE(config-if)#ip address 192.168.10.1 255.255.255.0
MALABE(config-if)#no shutdown
MALABE(config-if)#exit

MALABE(config)#interface serial 0/0/0
MALABE(config-if)#ip address 10.0.0.1 255.0.0.0
MALABE(config-if)#clock rate 64000
MALABE(config-if)#no shutdown

MALABE(config-if)#exit

For Router2
MATARA(config)#interface fastEthernet 0/0
MATARA(config-if)#ip address 192.168.12.1 255.255.255.0
MATARA(config-if)#no shutdown
MATARA(config-if)#exit

MATARA(config)#interface serial 0/0/0
MATARA(config-if)#ip address 11.0.0.2 255.0.0.0
MATARA(config-if)#no shutdown
MATARA(config-if)#exit

For Router0
METRO(config)#interface fastEthernet 0/0
METRO(config-if)#ip address 192.168.11.1 255.255.255.0
METRO(config-if)#no shutdown
METRO(config-if)#exit

METRO(config)#interface serial 0/0/0
METRO(config-if)#ip address 10.0.0.2 255.0.0.0
METRO(config-if)#no shutdown

METRO(config-if)#exit
METRO(config)#interface serial 0/0/1
METRO(config-if)#ip address 11.0.0.1 255.0.0.0
METRO(config-if)#clock rate 64000
METRO(config-if)#no shutdown

METRO(config-if)#exit

Step6 : Configure the PC’s. (IP address, Subnet Mask and Default Gateway).











Configure the routers with RIP and IGRP to enable dynamic routing.

Dynamic routing could be done using Interior Gateway Protocols (IGP) and Exterior Gateway Protocols (EGP). We apply IGP for LANs and EGP for WANs.

IGRP, EIGRP, RIP and OSPF are some of these IGPs and BGP is an example for EGP.

First let’s see how to perform routing using RIP

Here for each router we have to use RIP and consider the directly connected network addresses of them to perform this routing.

MALABE(config)#router rip
MALABE(config-router)#network 192.168.10.0
MALABE(config-router)#network 10.0.0.0

METRO(config)#router rip
METRO(config-router)#network 10.0.0.0
METRO(config-router)#network 11.0.0.0
METRO(config-router)#network 192.168.11.0

MATARA(config)#router rip
MATARA(config-router)#network 192.168.12.0
MATARA(config-router)#network 11.0.0.0

Use ‘ping’ command to check the connectivity.

For PC0
PC>ipconfig

IP Address......................: 192.168.10.2
Subnet Mask.....................: 255.255.255.0
Default Gateway.................: 192.168.10.1

PC>ping 192.168.11.2

Pinging 192.168.11.2 with 32 bytes of data:

Reply from 192.168.11.2: bytes=32 time=94ms TTL=126
Reply from 192.168.11.2: bytes=32 time=94ms TTL=126
Reply from 192.168.11.2: bytes=32 time=79ms TTL=126
Reply from 192.168.11.2: bytes=32 time=73ms TTL=126

Ping statistics for 192.168.11.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 73ms, Maximum = 94ms, Average = 85ms

PC>ping 192.168.12.2

Pinging 192.168.12.2 with 32 bytes of data:

Reply from 192.168.12.2: bytes=32 time=111ms TTL=125
Reply from 192.168.12.2: bytes=32 time=109ms TTL=125
Reply from 192.168.12.2: bytes=32 time=125ms TTL=125
Reply from 192.168.12.2: bytes=32 time=110ms TTL=125

Ping statistics for 192.168.12.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 109ms, Maximum = 125ms, Average = 113ms

PC>


For PC1

PC>ipconfig

IP Address......................: 192.168.12.2
Subnet Mask.....................: 255.255.255.0
Default Gateway.................: 192.168.12.1

PC>ping 192.168.10.2

Pinging 192.168.10.2 with 32 bytes of data:

Reply from 192.168.10.2: bytes=32 time=125ms TTL=125
Reply from 192.168.10.2: bytes=32 time=125ms TTL=125
Reply from 192.168.10.2: bytes=32 time=125ms TTL=125
Reply from 192.168.10.2: bytes=32 time=125ms TTL=125

Ping statistics for 192.168.10.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 125ms, Maximum = 125ms, Average = 125ms

PC>ping 192.168.12.2

Pinging 192.168.12.2 with 32 bytes of data:

Reply from 192.168.12.2: bytes=32 time=0ms TTL=128
Reply from 192.168.12.2: bytes=32 time=15ms TTL=128
Reply from 192.168.12.2: bytes=32 time=0ms TTL=128
Reply from 192.168.12.2: bytes=32 time=15ms TTL=128

Ping statistics for 192.168.12.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 15ms, Average = 7ms


For PC2
PC>ipconfig

IP Address......................: 192.168.11.2
Subnet Mask.....................: 255.255.255.0
Default Gateway.................: 192.168.11.1

PC>ping 192.168.10.0

Pinging 192.168.10.0 with 32 bytes of data:

Reply from 10.0.0.1: bytes=32 time=63ms TTL=254
Reply from 10.0.0.1: bytes=32 time=63ms TTL=254
Reply from 10.0.0.1: bytes=32 time=63ms TTL=254
Reply from 10.0.0.1: bytes=32 time=62ms TTL=254

Ping statistics for 192.168.10.0:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 62ms, Maximum = 63ms, Average = 62ms

PC>ping 192.168.12.2

Pinging 192.168.12.2 with 32 bytes of data:

Reply from 192.168.12.2: bytes=32 time=93ms TTL=126
Reply from 192.168.12.2: bytes=32 time=94ms TTL=126
Reply from 192.168.12.2: bytes=32 time=94ms TTL=126
Reply from 192.168.12.2: bytes=32 time=94ms TTL=126

Ping statistics for 192.168.12.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 93ms, Maximum = 94ms, Average = 93ms

PC>


Now let’s see how to perform routing using EIGRP

EIGRP is also an Interior Gateway protocol which is applied to one autonomous system. So to apply it, first we should have the same Autonomous number for all the networks. Otherwise all PC in the Autonomous system cannot communicate.
How to apply?

Note:-do not use many protocols at the same time. If so, first remove all the previous routing commands and then use EIGRP (In this case…type…no router rip in each router)

MALABE(config)#router eigrp 200
MALABE(config-router)#network 192.168.10.0
MALABE(config-router)#network 10.0.0.0

METRO(config)#router eigrp 200
METRO(config-router)#network 10.0.0.0
METRO(config-router)#network 11.0.0.0
METRO(config-router)#network 192.168.11.0

MATARA(config)#router eigrp 200 
MATARA(config-router)#network 192.168.12.0
MATARA(config-router)#network 11.0.0.0

According to the methods shown above routing could be done statically or dynamically by using routing protocols (or even by default) to route different networks to communicate with each other.

Static Routing and Default Routing Configurations















Use the knowledge you gain from the previous posts of router configuration since this activity needs knowledge up to static routing and we are going to learn something called Default routing here something which is similar to static routing.

Step1 

Design the above network and load it in to Packet Tracer Simulator.
(Router 2811 has 1 Ethernet and 2 Serial interfaces.Select R1 – S0 and R2 – S1 as DCE side for clocking inside the simulator)


















For R1 and R2, use 1841 routers and add single serial port for each.


















Since R3 needs two serial ports, use 1841 router but add two serial ports as shown above.

Step2

Name R1, R2 and R3 as Malabe, Metro and Matara.

For R0 -->
Router(config)#hostname MALABE

For R1 -->
Router(config)#hostname METRO

For R2 -->
Router(config)#hostname MATARA

Step3

Design a suitable IP plan for the above networks.Note: Subnetting can be applied. (eg. 10.1.0.0 255.255.0.0)


Applying Subnetting

Assume that the given Network address is 192.168.10.0 It belongs to class C. Therefore cannot harm to the first three Bytes. We have to make 5 subnets (3 LANs and 2 WANs) we can go for creating 8 subnets using 3 bits from the host side of the given Network address (23)

It's easy if you write the host ID expanded in binary to represent the eight bits meanwhile e leaving the network ID part as it is because we are not suppose to change it.

The possible combinations are:-

 Sub net addresses |   possible IP addresses
192.168.10.0000 0000 à 192.168.10.0         192.168.10.0   X because it is the network address of subnet zero
                                                            192.168.10.1                                                                
                                                            192.168.10.2
                                                            192.168.10.31 X because it is the DB address of subnet zero

192.168.10.0010 0000 à 192.168.10.32       192.168.10.32 X because it is the network address of subnet 1
                                                            192.168.10.33                                                             
                                                            192.168.10.34
                                                            192.168.10.63 X because it is the DB address of subnet 1

192.168.10.0100 0000 à 192.168.10.64       192.168.10.64 X because it is the network address of subnet 2
                                                            192.168.10.65                                                             
                                                            192.168.10.66
                                                            192.168.10.95 X because it is the DB address of subnet 2

192.168.10.0110 0000 à 192.168.10.96       192.168.10.96 X because it is the DB address of subnet 3
                                                            192.168.10.97                                                             
                                                            192.168.10.98
                                                            192.168.10.127 X because it is the DB address of subnet 3
192.168.10.1000 0000 à 192.168.10.128     192.168.10.128 X because it is the network address of subnet 4
                                                            192.168.10.129                                                          
                                                            192.168.10.130
                                                            192.168.10.159 X because it is the DB address of subnet 4

192.168.10.1010 0000 à 192.168.10.160     192.168.10.160 X because it is the network address of subnet 5
                                                            192.168.10.161                                                          
                                                            192.168.10.162
                                                            192.168.10.191 X because it is the DB address of subnet 5

192.168.10.1100 0000 à 192.168.10.192     192.168.10.192 X because it is the network address of subnet 6
                                                            192.168.10.193                                                          
                                                            192.168.10.194
                                                            192.168.10.223 X because it is the DB address of subnet 6

192.168.10.1100 0000 à 192.168.10.224     192.168.10.224 X because it is the network address of subnet 7
                                                            192.168.10.225                                                          
                                                            192.168.10.226
Note that the IP addresses within the above shown purple colored addresses for each subnet could be used as valid IP addresses for each sub network’s hosts. Make sure to omit the network address and direct broadcast (DB) address in each sub network. Since we only need two IP addresses for each of our five networks, simply the first two IPs could be used.

Step4 

Configure the Serial and Ethernet interfaces of routers and assign clock rate as 64000 for the R1 serial 0 and R2 serial 1 interfaces.

For Router1
MALABE(config)#interface fastEthernet 0/0
MALABE(config-if)#ip address 192.168.10.1 255.255.255.224
MALABE(config-if)#no shutdown

MALABE(config-if)#exit
MALABE(config)#interface serial 0/0/0
MALABE(config-if)#ip address 192.168.10.97 255.255.255.224
MALABE(config-if)#clock rate 64000

MALABE(config-if)#no shutdown
MALABE(config-if)#exit

For Router2
MATARA(config)#interface fastEthernet 0/0
MATARA(config-if)#ip address 192.168.10.65 255.255.255.224
MATARA(config-if)#no shutdown

MATARA(config-if)#exit
MATARA(config)#interface serial 0/0/0
MATARA(config-if)#ip address 192.168.10.130 255.255.255.224
MATARA(config-if)#no shutdown
MATARA(config-if)#exit

For Router3
METRO(config)#interface fastEthernet 0/0
METRO(config-if)#ip address 192.168.10.33 255.255.255.224
METRO(config-if)#no shutdown

METRO(config-if)#exit
METRO(config)#interface serial 0/0/0
METRO(config-if)#ip address 192.168.10.98 255.255.255.224
METRO(config-if)#no shutdown

METRO(config-if)#exit
METRO(config)#interface serial 0/0/1
METRO(config-if)#ip address 192.168.10.129 255.255.255.224
METRO(config-if)#clock rate 64000
METRO(config-if)#no shutdown

METRO(config-if)#exit




Step5

Configure the PC’s. (IP address, Subnet Mask and Default Gateway)


Step6

Use ‘ping’ command to check the connectivity.

IP Address......................: 192.168.10.2
Subnet Mask.....................: 255.255.255.224
Default Gateway.................: 192.168.10.1

PC>ping 192.168.10.1

Pinging 192.168.10.1 with 32 bytes of data:

Reply from 192.168.10.1: bytes=32 time=63ms TTL=255
Reply from 192.168.10.1: bytes=32 time=32ms TTL=255
Reply from 192.168.10.1: bytes=32 time=32ms TTL=255
Reply from 192.168.10.1: bytes=32 time=31ms TTL=255

Ping statistics for 192.168.10.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 31ms, Maximum = 63ms, Average = 39ms

PC>ping 192.168.10.34

Pinging 192.168.10.34 with 32 bytes of data:

Reply from 192.168.10.1: Destination host unreachable.
Reply from 192.168.10.1: Destination host unreachable.
Reply from 192.168.10.1: Destination host unreachable.
Reply from 192.168.10.1: Destination host unreachable.

Ping statistics for 192.168.10.34:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

PC>ping 192.168.10.66

Pinging 192.168.10.66 with 32 bytes of data:

Reply from 192.168.10.1: Destination host unreachable.
Reply from 192.168.10.1: Destination host unreachable.
Reply from 192.168.10.1: Destination host unreachable.
Reply from 192.168.10.1: Destination host unreachable.

Ping statistics for 192.168.10.66:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

PC>

The above ping commands of PC0 summarizes that still the data exchange could be done successfully within Local Networks only. Networks still cannot identify their remote networks successfully. So we need to route to perform that task.

Step7 

Assign Static Routing to all the routers and check the connectivity.

Static routing is done by the administrator to make the remote networks of each network to identify and exchange data when the remote network addresses and subnet masks are known.


Assigning Default Routing to necessary routers.

Default routing is kind of similar to static routing but this is done when the network administrator doesn’t know the exact network addresses and subnet masks of remotely situated networks.

Note: - If we need to perform default routing to the same networks that we have already done static routing, then first we need to remove the static routing commands from them and then assign default routing commands.

To remove all the static routings use the below shown commands for each.

MALABE(config)#no ip route 192.168.10.64 255.255.255.0 192.168.10.98
MALABE(config)# no ip route 192.168.10.32 255.255.255.0 192.168.10.98

METRO(config)# no ip route 192.168.10.0 255.255.255.0 192.168.10.97
METRO(config)# no ip route 192.168.10.64 255.255.255.0 192.168.10.130

MATARA(config)#no ip route 192.168.10.0 255.255.255.0 192.168.10.129
MATARA(config)# noip route 192.168.10.32 255.255.255.0 192.168.10.129

How to set default routing…

MALABE(config)# ip route 0.0.0.0 0.0.0.0 192.168.10.98
METRO(config)# ip route 0.0.0.0 0.0.0.0 192.168.10.97
MATARA(config)# ip route 0.0.0.0 0.0.0.0 192.168.10.129

Note :- Since we don’t know the destination Network addresses and subnet masks, we simply assign them as 0.0.0.0 but the default gateway, what we already should know should be assigned as it is.

Final Step

Check the connectivity again.
PC>ipconfig

IP Address......................: 192.168.10.2
Subnet Mask.....................: 255.255.255.224
Default Gateway.................: 192.168.10.1

PC>ping 192.168.10.1

Pinging 192.168.10.1 with 32 bytes of data:

Reply from 192.168.10.1: bytes=32 time=31ms TTL=255
Reply from 192.168.10.1: bytes=32 time=31ms TTL=255
Reply from 192.168.10.1: bytes=32 time=31ms TTL=255
Reply from 192.168.10.1: bytes=32 time=31ms TTL=255

Ping statistics for 192.168.10.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 31ms, Maximum = 31ms, Average = 31ms
PC>ping 192.168.10.34

Pinging 192.168.10.34 with 32 bytes of data:

Reply from 192.168.10.34: bytes=32 time=109ms TTL=124
Reply from 192.168.10.34: bytes=32 time=125ms TTL=124
Reply from 192.168.10.34: bytes=32 time=125ms TTL=124
Reply from 192.168.10.34: bytes=32 time=125ms TTL=124

Ping statistics for 192.168.10.34:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 109ms, Maximum = 125ms, Average = 121ms

PC>ping 192.168.10.66

Pinging 192.168.10.66 with 32 bytes of data:

Reply from 192.168.10.66: bytes=32 time=125ms TTL=125
Reply from 192.168.10.66: bytes=32 time=125ms TTL=125
Reply from 192.168.10.66: bytes=32 time=109ms TTL=125
Reply from 192.168.10.66: bytes=32 time=125ms TTL=125

Ping statistics for 192.168.10.66:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 109ms, Maximum = 125ms, Average = 121ms

PC>

Now the data exchange throughout the network is done successfully.

Do not forget to copy the running-config files to the startup configuration files as shown below. This makes the running-configuration information (that are volatile and lost when the router is switched off). To non-volatile memory in NVRAM.

MALABE#copy running-config  startup-config
METRO#copy running-config startup-config
MATARA#copy running-config startup-config

No comments:

Post a Comment